2009年03月24日

RubyのXML構文解析系ライブラリNokogiri 1.2以降はhoe 0.9以上が必要5

超多忙です。。。 RubyのXML構文解析系ライブラリNokogiri 1.2以降はhoe 0.9以上が必要のようです。
$ gem list

*** LOCAL GEMS ***

nokogiri (1.1.0)
だったものを
$ sudo gem update
Updating installed gems
Updating nokogiri
Building native extensions.  This could take a while...
Successfully installed nokogiri-1.2.2
Gems updated: nokogiri
ってやった。ら、
$ sudo gem list

*** LOCAL GEMS ***

nokogiri (1.2.2, 1.1.0)
となった。当たり前。で、
$ ruby foobar.rb
/usr/lib/ruby/1.8/rubygems.rb:578:in `report_activate_error': Could not find RubyGem hoe (>= 1.9.0) (Gem::LoadError)
	from /usr/lib/ruby/1.8/rubygems.rb:134:in `activate'
	from /usr/lib/ruby/1.8/rubygems.rb:158:in `activate'
	from /usr/lib/ruby/1.8/rubygems.rb:157:in `each'
	from /usr/lib/ruby/1.8/rubygems.rb:157:in `activate'
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from /usr/lib/ruby/1.8/www/mechanize.rb:9
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
	from /usr/lib/ruby/1.8/mechanize.rb:7
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
	from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
	from get_money.rb:6
ってなっちゃったので、
$ sudo gem install hoe
Successfully installed rubyforge-1.0.3
Successfully installed rake-0.8.4
Successfully installed hoe-1.11.0
3 gems installed
Installing ri documentation for rubyforge-1.0.3...
Installing ri documentation for rake-0.8.4...
Installing ri documentation for hoe-1.11.0...
Installing RDoc documentation for rubyforge-1.0.3...
Installing RDoc documentation for rake-0.8.4...
Installing RDoc documentation for hoe-1.11.0...
でした。

ayucat at 23:40│Comments(0)TrackBack(0) Ruby 

トラックバックURL

この記事にコメントする

名前:
URL:
  情報を記憶: 評価: 顔   
 
 
 
最速グルメ検索研究会(Hダイアリー)