先日のアップデートで、通称「 BLT 」を基礎とする MOD が仕様不可能になっていた
私も同じくで、解決方法を探したところフォーラムで解決方法発見報告があり
行った所、見事にいくつかのMODは使用可能になった

2017年11月現在下記で紹介している方法では
BLT2.3でしかMODが正しく機能しない若しくはゲームがクラッシュします


payday2-blog












_______________________________________________________
9/7追記
BLTのバグなどが解消されたver 2.2が公開されています

ただし、BLTの基礎プログラムが大幅に変更となった為
2.0以降に対応するアップデートを行っていないMODは使用不可能です
どれが対応したかは自分で確認してアップデートを行う必要があります
未だ未対応のMODを使いたい場合は以下の2.0と1.08の組み合わせするしかありません

日本語化MODに関してですが管理人様がどうやらずいぶんと前から
活動を停止している模様で、STEAMのグループ掲示板にて別の方が
「新しい日本語化に挑戦してみるか検討中」のようです

また、有志の方が暫定版という形で
BLTのver.1.08~2.2対応のJPMODをTwitterで公開をされています
私も、それをダウンロードして導入したところ日本語化できました
twitter直リンクは有志の方に迷惑になるので、日本語化したい方は
PAYDAY2日本語化MODのダウンロード&インストールのコメント欄を見てください

_______________________________________________________

ver1.08とver2.0のミックスBLT導入方法

https://github.com/JamesWilko/Payday-2-BLT/releases

上記URLから、ver 2.0 と ver 1.08 を両方ダウンロード

2.0を解凍し「 IPHLPAPI.dll 」 ファイルだけを導入
1.08を解凍し、IPHLPAPI.dll 以外のファイルやフォルダを導入
これで、BLTが使用可能になった(私の環境では)

BLTの導入が分からない方はこちらの記事を参照してください


PAY DAY 2 BLT や 日本語化 HUD 等 MOD の 導入方法