何の気なしにNet::Twitterをcpanで更新したら、Twitterのbotが日本語で発言できなくなった。

具体的に言うと、Net::Twitterの3.13003でOAuth認証を使っていて、フォロー/リムーブやタイムライン取得はでき、更に日本語を含まない文ならばpostできるのだが、日本語を含む文をpostしようとすると、"incorrect signature"と出てpostできない。

ぐぐっても同じ症例がないので、とりあえずNet::Twitterのバージョンを3.13001に戻してやると、元通りpostできるようになった。

バグだったのかどうかは分からないkが、仮にバグだとしたら、日本語をpostできないって結構重大だと思うんだけど、ぐぐっても同じ症例の人が全然いなかったんですが・・・。よくわからん。