2009年02月01日 21:30 [Edit]

perl - Encode-2.29 Released! (2.28 deleted)

2.27でUnicode.xsがRefactorされたのですが、そこで使っているAPIが新し過ぎたため、Perl 5.8.6以前のperlの互換性が失われてしまいました。本releaseはそれを直します。

なお、2.28はPAUSEのアップロードエラー対策のため欠番となります。やれやれ。

$Revision: 2.29 $ $Date: 2009/02/01 13:14:37 $
! Encode.pm
 VERSION++ just to make PAUSE happy
 Message-Id: <877i4anwwt.fsf@k75.linux.bogus>

2.28 Date: 2009/02/01 12:30:18
! Unicode/Unicode.xs
 Latest refactoring broke the backward compatibility
 w/ Perl 5.8.6 and before now restored
 Message-Id: <1233185156.DABa130.74940@basic2.hostingcompartido.com>
 Message-Id: <693254b90902010027x277a5d0fm4f5700ba2f276239@mail.gmail.com>
! lib/Encode/MIME/Header.pm
 Addressed: Split header lines are joined incorrectly
 http://rt.cpan.org/Ticket/Display.html?id=42902
Dan the Encode Maintainer

この記事へのトラックバックURL

この記事へのトラックバック
Encode 2.30 を Release したのでお知らせします。 /lang/perl/Encode/trunk - CodeRepos::Share - Trac Dan Kogai / Encode - search.cpan.org http://www.dan.co.jp/~dankogai/cpan/Encode-2.30.tar.gz
perl - Encode-2.30 Released!【404 Blog Not Found】at 2009年02月16日 03:01
この記事へのコメント
Encodeにはお世話になっております。

s/Encode 2.28 を Release /Encode 2.29 を Release /;
Posted by akira at 2009年02月02日 10:54