RouterBOARDのCLIでIPアドレスを変更する。

WinBoxやWebFigではIPの変更を行える方は多いのですが、
CLIからIPを直接変更する処理はどうするのか?

という事で、インターフェイスとIPアドレスの変更を行ってみましょう。

TerminalやSSHでターミナルへloginします。

まず、interfaceのipアドレスの確認を行います。

[admin@MikroTik] > /ip address print        
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE                                                                                                
 0   ;;; default configuration
     192.168.190.10/24   192.168.190.0    ether3-slave-local                                                                                       
 1 D xxx.yyy.zzz.51/32   zzz.yyy.xxx.1   pppoe-out1
                    

では、Eth3のipアドレスを変更します。
設定コマンドは
/ip address set interface= address= netmask= network= numbers=

interface=インターフェイスネーム
address=ipアドレス 例:192.168.50.1/24
netmask=255.255.255.0 例:サブネットマスク値
network=192.168.50.0 例:ネットワークセグメント
numbers=0 Interface番号

設定に必要なパラメーターはTabキーで表示されます。

[admin@MikroTik] > /ip address set address=192.168.50.1/24 (tab)
broadcast  comment  disabled  interface  netmask  network  numbers

[admin@MikroTik] > /ip address set address=192.168.90.10/24 interface= (tab)
bridge-local  bridge1 ether3-slave-local pppoe-out1  pptp-in1  sfp1  pptp-out1

例:192.168.90.10へether3-slave-localのIPを変更する
[admin@MikroTik] > /ip address set address=192.168.90.10/24 interface=ether3-slave-local netmask=255.255.255.0 network=192.168.90.0 numbers=0

numbers:とでますが、そのままリターンで設定されます。(←※追記・IF番号を指定してください)


以上でIPアドレスを変更する事ができます。
メインIPを変更するとWinbox等が反応しなくなりますので、一度落ちてIP変更を確認してください。


hAP AC(以下hAP-AC)を2台使った簡易オフィス環境ネットワークの構築を行ってみましょう。
今回の事例は横に長いフロアで有線・無線クライアントを収容する想定です。
2台のhAP-AC間にLANケーブルの敷設ができない事とし、WDSによる無線接続を行います。
hAP-ACは2波を同時に利用する事ができるので、このような事例には便利な無線ルーターです。
OS-Level4のライセンスを搭載しているので、各種pppプロトコルやIPSec等トンネルも利用可能。
(L2TP/IPSecでIKEv2が最新のRCで実装されました。)
収容台数が多い場合はhAP-ACをL2APとして利用し、上流にキャパの大きなルーターを
配置する事で、収容キャパを増やす事も可能です。
hap-office2

●収容はONUからPPPoEの払い出しでIPv4を収容
●クライアント向け無線の払い出しは5GHz、WDS間通信は2.4GHz
●hAP-1、hAP-2間のクライアント無線通信の分離
hap-office
設定に必要な項目は以下の通り。

1)PPPoEのインターフェイス並びに接続設定
 pppインターフェイスの作成、PPPoEクライアント設定
2)各接続インターフェイスのIP設定
 有線・無線収容用のBridgeインターフェイス作成、IP設定
3)2.4GHz WDS用に無線の設定
 WDS用のProfile作成、2.4GHzの無線設定、WDS設定
4)5GHzのクライアント接続用に無線の設定、接続ユーザー設定
 クライアント接続Profile作成、5GHzの無線設定、SecurityProfile作成
5)IP払い出しの設定(DHCP)
 各IP払い出し範囲の設定、DHCPサーバーの設定
5)Routeの設定、FireWall,NATの設定
 デフォルトゲートウェー設定、各インターフェイスからの相互NAT設定、各種フィルタ設定
6)SW向けのVLAN設定
 各スイッチへのVLAN設定




▼(1)各接続インターフェイスのIP設定
有線・無線収容用のBridgeインターフェイス作成、IP設定します。

○hAP-1にETH5を管理用に設定し、Bridgeを4つ作成します。

Interface->Interface
インターフェイス5をダブルクリック
Master Portがnoneになっている事を確認、なっていなければnoneへ

IP->Address
+(ADD)

Address: 192.168.50.1/24
Network:192.168.50.0
Interface:ETH5 ←インターフェイス5番を選択

これで、5番ポートにIPが設定できましたので、
変更したIPで接続してください。

【CLI】
/ip address
add address=192.168.50.1/24 interface=ETH5 network=192.168.50.0

次に、以下のBridgeを作成します。

Bridge-wds -WDS接続用
Bridge-wan -無線接続用
Bridge-lan1 -有線接続用1
Bridge-lan2 -有線接続用2

Bridge->Bridge
+(ADD)

[Bridge-General]
Name:ブリッジ名前 Bridge-wds
他のパラメーターは今回いじらないのでOKで作成

[Port]
+(ADD)
[General]
Interface: wlan1 ←デフォルトではwlan1が2.4GHz wlan2が5Ghz
Bridge: Bridge-wds

+(ADD)
[Bridge-General]
Name:ブリッジ名前 Bridge-wan
他のパラメーターは今回いじらないのでOKで作成

[Port]
+(ADD)
[General]
Interface: wlan2 ←デフォルトではwlan1が2.4GHz wlan2が5Ghz
Bridge: Bridge-wan

+(ADD)
[Bridge-General]
Name:ブリッジ名前 Bridge-lan1
他のパラメーターは今回いじらないのでOKで作成

[Port]
+(ADD)
[General]
Interface: ETH2
Bridge: Bridge-lan1

+(ADD)
[Bridge-General]
Name:ブリッジ名前 Bridge-lan2
他のパラメーターは今回いじらないのでOKで作成

[Port]
+(ADD)
[General]
Interface: ETH3
Bridge: Bridge-lan2

※インターフェイスの名前や構成は初期テンプレートが入っていると
うまく切れない場合がありますので、調整してください。
(Master/SlaveをNoneにして分離、名前もわかりやすい物へ変更)

【CLI】
/interface bridge port
add bridge=bridge-wan interface=wlan1
add bridge=bridge-wan interface=wlan2
add bridge=bridge-lan1 interface=ETH2
add bridge=bridge-lan2 interface=ETH3


各bridgeへIPを設定

IP->Address
+(ADD)
Address: 10.1.1.1/24
Network:10.1.1.0
Interface:Bridge-lan1

+(ADD)
Address: 10.2.1.1/24
Network:10.2.1.0
Interface:Bridge-lan2

+(ADD)
Address: 10.3.1.1/24
Network:10.3.1.0
Interface:Bridge-wds

+(ADD)
Address: 10.4.1.1/24
Network:10.4.1.0
Interface:Bridge-wan

【CLI】
/ip address
add address=10.1.1.1/24 interface=Bridge-lan1 network=10.1.1.0
add address=10.2.1.1/24 interface=Bridge-lan2 network=10.2.1.0
add address=10.3.1.1/24 interface=Bridge-wds network=10.3.1.0
add address=10.4.1.1/24 interface=Bridge-wan network=10.4.1.0



○hAP-2にETH5を管理用に設定し、Bridgeを2つ作成します。

Interface->Interface
インターフェイス5をダブルクリック
Master Portがnoneになっている事を確認、なっていなければnoneへ

IP->Address
+(ADD)

Address: 192.168.50.2/24
Network:192.168.50.0
Interface:ETH5 ←インターフェイス5番を選択

【CLI】
/ip address
add address=192.168.50.2/24 interface=ETH5 network=192.168.50.0

これで、5番ポートにIPが設定できましたので、
変更したIPで接続してください。

次に、以下のBridgeを作成します。

Bridge-wds -WDS接続用
Bridge-wan -無線接続用


Bridge->Bridge
+(ADD)

[Bridge-General]
Name:ブリッジ名前 Bridge-wds
他のパラメーターは今回いじらないのでOKで作成

[Port]
+(ADD)
[General]
Interface: wlan1 ←デフォルトではwlan1が2.4GHz wlan2が5Ghz
Bridge: Bridge-wds

+(ADD)
[Bridge-General]
Name:ブリッジ名前 Bridge-wan
他のパラメーターは今回いじらないのでOKで作成

[Port]
+(ADD)
[General]
Interface: wlan2 ←デフォルトではwlan1が2.4GHz wlan2が5Ghz
Bridge: Bridge-wan

【CLI】
/interface bridge port
add bridge=bridge-wan interface=wlan1
add bridge=bridge-wan interface=wlan2


各bridgeへIPを設定

IP->Address
+(ADD)
Address: 10.3.1.2/24
Network:10.3.1.0
Interface:Bridge-wds

+(ADD)
Address: 10.5.1.1/24
Network:10.4.1.0
Interface:Bridge-wan

【CLI】
/ip address
add address=10.3.1.1/24 interface=Bridge-wds network=10.3.1.0
add address=10.5.1.1/24 interface=Bridge-wan network=10.5.1.0


▼(2)PPPoEのインターフェイス並びに接続設定
hAP-1へETH1をONU側に接続してEth1からPPPoE接続でWAN側のIPを取得させます。

PPP->Interface
+(ADD) PPPoE Client

[General]
NAME:pppoe-out1 ← Interfaceの名前
Max MTU: このインターフェイスのMTU OCNなら1452辺り
Max MRU:

Interface: PPPoEを動かすインターフェイス 今回の事例ならETH1
8
[DialOut]
User: PPPoE接続用ユーザー名
Password: PPPoE接続用パスワード

Use Peer DNS チェック
Add Default Route チェック

Allow
chap/pap チェック

【CLI】
/interface pppoe-client
add add-default-route=yes allow=pap,chap default-route-distance=1 disabled=no interface=ETH1 max-mru=1454 max-mtu=1454 name=pppoe-out1 password="PPPoE接続パスワード" use-peer-dns=yes user="PPPoE接続ユーザー名"

接続情報が問題なければ

[Status]
Link Up time
Uptime
MTU
MRU
Local Address
Remote Address
Active Links
Active AC Name
AC MAC Address

上記が表示されます。


▼(3)2.4GHz WDS用に無線の設定
WDSを使う事で、2つの無線APが有線でつながっているように通信する事が出来ます。

WDS用のSSID:Wds-Interface-wlan とする。
今回の設定ではWDS-Securityは導入しない。SSIDでの接続制御となるので、
できるだけ長いSSIDを設定する事

○hAP-1 hAP2間の接続用にWDSを設定、hAP-1の設定。

WDS接続用のSecurity Profileを作成
Wireless->Security Profile
+(ADD)

Name:wds-profile
Mode:none

【CLI】
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed name=wds-prof supplicant-identity=""


Wireless->Interface
wlan1をダブルクリック

[Wireless]
右のAdvance Modeを押す

Mode:ap bridge
Band:2GHz-B/G/N
Channel Width:20/40MHz Ce
Frequancy:2412
SSID: Wds-Interface-wlan
ScanList:default
WIewless Protocol:802.11
Security Profile:wds-profile

Freequancy Mode:regulatory-domain
Country:japan

Hide SSID チェック

[Wireless-WDS]
WDS Mode:dynamic
WDS Default Bridge: Bridge-wds

【CLI】
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country=japan disabled=no distance=indoors frequency-mode=regulatory-domain  hide-ssid=yes mode=ap-bridge security-profile=wds-prof ssid=Wds-Interface-wlan wds-default-bridge=bridge-wds wds-mode=dynamic wireless-protocol=802.11


○hAP-1 hAP2間の接続用にWDSを設定、hAP2の設定。

WDS接続用のSecurity Profileを作成
Wireless->Security Profile
+(ADD)

Name:wds-profile
Mode:none

【CLI】
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed name=wds-prof supplicant-identity=""


Wireless->Interface
wlan1をダブルクリック

[Wireless]

右のAdvance Modeを押す

Mode:ap bridge
Band:2GHz-B/G/N
Channel Width:20/40MHz Ce
Frequancy:2412
SSID: Wds-Interface-wlan
ScanList:default
WIewless Protocol:802.11
Security Profile:wds-profile

Freequancy Mode:regulatory-domain
Country:japan

Hide SSID チェック

[Wireless-WDS]
WDS Mode:dynamic
WDS Default Bridge: Bridge-wds

【CLI】
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country=japan disabled=no distance=indoors frequency-mode=regulatory-domain hide-ssid=yes mode=ap-bridge security-profile=wds-prof ssid=Wds-Interface-wlan wds-default-bridge=bridge-wds wds-mode=dynamic wireless-protocol=802.11

正常につながると、Wireless->Interfaceにwdsインターフェイスが表示され、
相手のwdsインターフェイスが表示される。


▼(4)5GHzのクライアント接続用に無線の設定、接続設定
クライアント接続Profile作成、5GHzの無線設定、SecurityProfile作成
無線クライアントの接続用にhAP-1、hAP-2に5GHzの設定を行う。

○hAP-1へ設定

ここのSecurityProfileで5GHzのSSIDに対してのパスワード設定を行います。
WAN接続用のSecurity Profileを作成
Wireless->Security Profile
+(ADD)

Name:wan-profile
Mode:dynamic-keys
Auth-Type:WPA PSK/WPA2 PSK チェック
Unicast Ciphers aes ccm チェック
Group Ciphers aes ccm チェック
WPA  Pre-Shard Key:接続用キー hAP-1接続用パスワード(WPA)
WPA2  Pre-Shard Key:接続用キー hAP-1接続用パスワード(WPA2)

【CLI】
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=wan-prof supplicant-identity="" wpa-pre-shared-key="接続用キー" wpa2-pre-shared-key="接続用キー"

Wireless->Interface
wlan2をダブルクリック

[Wireless]
右のAdvance Modeを押す

Mode:ap bridge
Band:5GHz-a/n/ac
Channel Width:20/40/80mhz-Ceee
Frequancy:5520
SSID: office-wlan002
ScanList:default
WIewless Protocol:802.11
Security Profile:wan-profile

Freequancy Mode:regulatory-domain
Country:japan

【CLI】
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=japan disabled=no distance=indoors frequency=5220 frequency-mode=regulatory-domain mode=ap-bridge security-profile=wan-prof ssid=office-wlan001 wireless-protocol=802.11



○hAP-2へ設定

WAN接続用のSecurity Profileを作成
Wireless->Security Profile
+(ADD)

Name:wan-profile
Mode:dynamic-keys
Auth-Type:WPA PSK/WPA2 PSK チェック
Unicast Ciphers aes ccm チェック
Group Ciphers aes ccm チェック
WPA  Pre-Shard Key:接続用キー hAP-2接続用パスワード(WPA)
WPA2  Pre-Shard Key:接続用キー hAP-2接続用パスワード(WPA2)

【CLI】
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=wan-prof supplicant-identity="" wpa-pre-shared-key="接続用キー" wpa2-pre-shared-key="接続用キー"

Wireless->Interface
wlan2をダブルクリック

[Wireless]
右のAdvance Modeを押す

Mode:ap bridge
Band:5GHz-a/n/ac
Channel Width:20/40/80mhz-Ceee
Frequancy:5280
SSID: office-wlan002
ScanList:default
WIewless Protocol:802.11
Security Profile:wan-profile

Freequancy Mode:regulatory-domain
Country:japan

【CLI】
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=japan disabled=no distance=indoors frequency=5280 frequency-mode=regulatory-domain mode=ap-bridge security-profile=wan-prof ssid=office-wlan001 wireless-protocol=802.11

以上でメインの設定は完成。
残りはIPの払い出しと外部へのルーティング・NAT・フィルターの設定を
行う事で完成となります。









続きを読む



RouterBOARDの搭載OS RouterOSには現在3つのリリースレーンがあります。

bugfix  旧カレントリリースから分離。ある程度のBugがつぶされている。
Current  カレントリリース、一応公式なRouterOSのリリースバージョン
RC 最新の実装を含むベーターリリース、Bugも豊富だが使える新機能、Bugfixも多い

通常の利用ではbugfixやCurrentを利用するのが無難です。
(Bugfixでは実装されてない機能を利用したい場合はCurrentを利用します。)

RouterOSのupdateと再インストール

RouterOSは通常RouterBOARDに出荷時、
ライセンスを含む形でインストールされ搭載されています。
ここに新しいOSをuploadして再起動する事で更新ができるのですが、
RC等を利用している場合、内部パラメーターの変更等でうまくコンフィグが引き継がれない等の
問題が発生する場合があります。(内部設定パラメーターがおかしくなる場合がある)

Update挙動としては、差分のモジュールと設定の部分を差し替えている感じですね。

この際は設定の初期化を行う事で大体正常に戻るのですが、
場合によってはこれで対応できない場合があります。
その際はUpdateでなくそのRouterOSのリリースをNANDへ直接書き込む事で、
クリーンな環境として再インストールする事ができます。


再インストールにはNetinstallを使う

RouterBOARDにはNetbootする機能があり、この機能で書き換え用のカーネルを起動させて、
NANDへOSを書き込む事が出来ます。この一連の作業をサポートするツールがnetinstallです。
netbootをさせる場合、RouterBOOTで本体の起動元をNANDからnetboot(bootp)に変更する必要があります。
コンソール搭載機種はコンソールからnetbootへ変更し、起動する事でnetbootできますが、
コンソール非搭載機種はなかなかどういう状態でbootしているのか、状態がつかめません。

この場合の起動方法は以下の通りです。
1)リセットボタンを何かで押しながら電源を投入
2)actの点滅を確認
3)act消灯、Etherのled消灯 act再点灯、Etherのled点灯、点滅
4)3を確認しながらストレージが表示されるまでリセットを押し続ける。
Etherの点滅を確認してもストレージが見えない場合は再度1からやり直してください。

bootpでRouterBOARDを起動させる前にNetinstallを起動、設定させます。
netinstallを管理者権限で起動させ、起動後、netbootingのボタンでnetinstallのIPを設定します。
Service enableのチェックを入れ、boot用のipアドレスを設定します。

下のファイルでinstallしたいRouterOSの格納フォルダを選択しておくと、
フォルダ内のRouterOSが表示されるようになります。

正常にストレージが表示されると、右上に認識しているRouterBOARDのsoftwareIDと
ライセンスKeyが表示されます。
これが表示されない場合はnetinstallを中止してください。
(別途ライセンスを抜かないとライセンスが消えます)

ストレージを選択すると、ファイルに当該のRouterOSが表示されます。
(MIPSBEならMIPSBEのOSのみ表示されます。)
あとは、インストールしたいOSを選択してINSTALLを押すと
NANDの初期化、パーテーション、OS転送、再起動まで行われます。

再起動後はnetinstallを終了してWebfigアクセス、もしくはWinbox等でアクセスできるか
確認を行ってください。

本来、RCリリースの変更はNetinstallで行うのが良いようですが、
通常の方法でも最近はそこそこ設定が引き継がれますので、
よほどの怪しい挙動がない限りはnetinstallは行わなくともよくなりました。

また、ブリック時(起動しない、bootloopする等)はnetinstallが必須となります。
RouterBOARDユーザーはnetinstallの練習をしておいた方が良いかもしれません。



続きを読む

↑このページのトップヘ