カテゴリ: 設定

RouterBOARDとmangleによるルーティング制御

RouterBOARDではパケットに対してmangleによるラベリングで
ルーティング制御を行う事ができます。
この回ではmangleを使用して、
mark connection
mark routing
mark packetを使った制御を記載予定です。

予定ではPCCまでの解説を行う予定です。

IMAG2370_1
The Dudeとは?
MikroTikのRouterOS/CapsMANと共に開発されている
監視ツールで、監視用agentsはRouterOS以外にSNMPを
利用できるので、SNMPをしゃべれる機器を監視可能。
簡単なトポロジ図をベースに帯域の監視や接続監視を行えます。

対応機器
サーバー:Tile(CCR)、mmips(hEXgr3)、arm(RB3011)、CHR
※x86マシンでDudeサーバーを動かす場合は
EsxやVirtualBox等でRouterOSを稼働させる必要があります。

今回はmmips搭載機のhEX Gr3でDudeサーバーを設定し、
連載で掲載したhAP AC 2台によるOFFICEネットワークの監視を設定を行い、
環境の監視設定を説明してゆく予定です。


続きを読む


RouterOSのアップデートファイルを定期的に確認し、自動でUpdateさせる。

RouterOSのカレントリリースを確認し、新しいカレントリリースがあった場合は
NETからRouterOSを取得し、再起動をかけてOS-UPDATEを行います。

Systsem->Scripts
新規で任意の名前で作成:例、Update-scripts

以下、中身-----------------------------------------------------------------
/system package update
check-for-updates once
:delay 1s;
:if ( [get status] = "New version is available") do={ install }
-------------------------------------------------------------------------------

System->Scheduler
新規で任意の名前で作成:例、OS-UPDATE
Interval: 1d 00:00:00に設定
一番下のOn Eventに
先ほどの、Update-scriptsを追加

これで、1日おきにUpdate-scriptsを実行させ、
Updateがあった場合は自動でダウンロードし、再起動をかけます。
StartUpTimeで起動時間を設定できます。
startupで再起動後の時間、任意に設定すれば、その時間から
1日おきにスクリプトを実行します。

※このスクリプトではRouterOSの問題に関係なくOSをUpdateします。
OSに起因する問題があっても、その判断はできませんので、特定用途で利用している場合は
注意が必要です。


RBで子機接続を行う(複数のクライアントに対して)

RouterBOARDの無線は色々設定できてわかりにくいと言われます。
確かに設定項目が多いのも確かですが、きちんと理解できればできる事は多いのです。

ここでは最低限、無線の設定ができる事を前提に設定を行います。

【子機モード設定】
WiMAXや各種無線親機に対して接続を行う場合はstationモードで接続を行います。

(1)あらかじめ、無線へ接続する為のパスワード情報を任意にSecurityProfileとして作成します。
たとえば、WiMAX-Profを作成し、接続パスワードと接続認証を設定
(2)無線のチャネル(2.4/5GHz)とAP-Modeをstationへ設定 ※ここでSSIDは設定しない
(3)AccessListに事前に抜いておいたWiMAX等の無線親機器のMACアドレスを登録(AP Access Rule)
MAC Address: 1C:B1:xx:xx:xx:xx
Interface:wlan2
Auth/forward をチェック
(4)ConnectionListに接続させる機器の登録(Station Connection Rule)
interface:wlan2
MAC Address:1C:B1:xx:xx:xx:xx
Connection チェック
SSID:この親機への接続SSID
Security Profile:先に登録したWiMAX-Prof

この設定を使う事で特定の親機が無線子機の範囲に入ると、
自動で接続プロファイルに基づいた接続を開始します。

複数のプロファイルを登録しておけば、
子機APが特定の無線親機に接続可能になると自動で接続できる設定が
構築できます。




RouterBOARDのCLIでIPアドレスを変更する。

WinBoxやWebFigではIPの変更を行える方は多いのですが、
CLIからIPを直接変更する処理はどうするのか?

という事で、インターフェイスとIPアドレスの変更を行ってみましょう。

TerminalやSSHでターミナルへloginします。

まず、interfaceのipアドレスの確認を行います。

[admin@MikroTik] > /ip address print        
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE                                                                                                
 0   ;;; default configuration
     192.168.190.10/24   192.168.190.0    ether3-slave-local                                                                                       
 1 D xxx.yyy.zzz.51/32   zzz.yyy.xxx.1   pppoe-out1
                    

では、Eth3のipアドレスを変更します。
設定コマンドは
/ip address set interface= address= netmask= network= numbers=

interface=インターフェイスネーム
address=ipアドレス 例:192.168.50.1/24
netmask=255.255.255.0 例:サブネットマスク値
network=192.168.50.0 例:ネットワークセグメント
numbers=0 Interface番号

設定に必要なパラメーターはTabキーで表示されます。

[admin@MikroTik] > /ip address set address=192.168.50.1/24 (tab)
broadcast  comment  disabled  interface  netmask  network  numbers

[admin@MikroTik] > /ip address set address=192.168.90.10/24 interface= (tab)
bridge-local  bridge1 ether3-slave-local pppoe-out1  pptp-in1  sfp1  pptp-out1

例:192.168.90.10へether3-slave-localのIPを変更する
[admin@MikroTik] > /ip address set address=192.168.90.10/24 interface=ether3-slave-local netmask=255.255.255.0 network=192.168.90.0 numbers=0

numbers:とでますが、そのままリターンで設定されます。(←※追記・IF番号を指定してください)


以上でIPアドレスを変更する事ができます。
メインIPを変更するとWinbox等が反応しなくなりますので、一度落ちてIP変更を確認してください。

↑このページのトップヘ